Email Sender
Incident Report for Edlio
Resolved
This incident has been resolved.
Posted Dec 22, 2020 - 12:55 PST
Investigating
Email Sender is currently experiencing degraded performance. Our team is investigating the issue.
Posted Dec 22, 2020 - 09:56 PST
This incident affected: Edlio CMS Websites (US & LATAM) (Admin Control Panel).