Website Outage
Incident Report for Edlio
Resolved
This incident has been resolved.
Posted Dec 15, 2021 - 08:23 PST
Investigating
Amazon web services is reporting an issue with their upstream provider US-WEST-2 which is impacting our platform.
Posted Dec 15, 2021 - 08:07 PST
This incident affected: Edlio CMS Websites (US & LATAM) (Public Sites, Admin Control Panel, Email System) and Mobile Applications (School News App).